Browser Versions No Longer Supported

As part of our efforts to ensure the security of your data while using our dashboard, Personal Capital is moving to only accept connections using TLS 1.2 or greater. Personal Capital is always applying the latest security standards and you may have noticed many banks, eCommerce sites and other major internet sites are doing the same this year. This means that some older web browsers which do not support TLS 1.2 may experience issues such as the the one displayed below.  To resolve this issue, update your browser to the latest version.

dsvgfdfsf.png

 

Browsers too old for new security

Update links

Chrome Version 1.0 through 29.0

https://www.google.com/chrome/

FireFox Version 1.0 through 26.0

https://www.mozilla.org/en-US/firefox/new/

Internet Explorer 1.0 through 10.0

https://www.microsoft.com/en-us/download/internet-explorer.aspx

Apple Safari 1.0 through 6.0

https://support.apple.com/downloads/safari

 

Here at Personal Capital, our users can trust their privacy is a top priority and we want to ensure that all your communications with our servers are properly secured and encrypted. Out of date encryption protocols can result in malicious persons viewing your data while it is transit. Using the latest encryption protocols for TLS (Transport Layer Security) will keep your data safe from those attacks.


Have more questions? Please Sign In to submit a request
Was this article helpful?
0 out of 0 found this helpful